[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [Fedora-xen] problems installing winxp with full virtualization on FC6



Yes, but for some reason on my system, the function keys don't work during
install.  I don't know if it is because it is a laptop or what - but
pressing F2, F5, F6, etc. at the appropriate times does nothing during
during setup.  I'll bet it does have something to do with it being a laptop
and the key mappings for the function keys perhaps.  

Were you on a laptop or normal keyboard???


-----Original Message-----
From: david parsley gmail com [mailto:david parsley gmail com] On Behalf Of
David Parsley
Sent: Monday, November 06, 2006 3:38 PM
To: Jeff Stockett
Subject: Re: [Fedora-xen] problems installing winxp with full virtualization
on FC6

Hi Jeff,

Dunno if this will work as well for you as it did for me, but here's what I
did:
When the XP installer asks you to press F6 to load drivers, instead
press F5, and select 'Standard PC ...'.  Apparently this instructs the
XP installer to use drivers for a simpler machine architecture.

Regards,
David

On 11/2/06, Jeff Stockett <jeff_301 msn com> wrote:
>
> Yep - I already tried that with the following results:
>
> apic    acpi
> 1       1       VM hangs with aforementioned apic error
> 0       1       VM crashes
> 1       0       VM crashes
> 0       0       VM hangs with aforementioned apic error
>
> I can post the dmesg info for the crash cases if you think that would be
helpful.  I may try grabbing vncclient from somewhere and seeing if I can
get the F5 hack to work on a fresh reinstall.  I think Xen will be quite
handy once the kinks are worked out and applaud the Fedora team for
attempting to make it easy and including it in FC6.  Thanks for your help.
--J
>
> ----------------------------------------
> > Date: Thu, 2 Nov 2006 23:31:56 +0000
> > From: berrange redhat com
> > To: jeff_301 msn com
> > CC: fedora-xen redhat com
> > Subject: Re: [Fedora-xen] problems installing winxp with full
virtualization on FC6
> >
> > On Thu, Nov 02, 2006 at 04:52:48PM -0600, Jeff Stockett wrote:
> > >
> > > I see from googling, that this bug has been reported once before
> > > (last month with a rawhide build) - but no answers. A little further
> > >  googling indicates that one possible workaround might be to hit F5
> > > (when it is asking for F6 to load drivers) during the setup process
> > > and specify the computer as not having APIC but the version of VNC
> > > or whatever console emulator that comes with Virtual Machine Manager
> > > doesn't seem to pass function keys thru (F2, F5, or F6 don't appear
> > > to work).  I'm at a loss on where to go from here, except to perhaps
> > > start compiling everything from latest sources (which would be alot
> > > of trouble).
> > >
> > > builder = "hvm"
> > > memory = "256"
> > > disk = [ 'phy:/dev/vg0/domuwinxp,hda,w', 'phy:/dev/hdb,hdc:cdrom,r' ]
> > > boot = 'c'
> > > vif = [ 'type=ioemu, mac=00:16:3e:45:71:31, bridge=xenbr0', ]
> > > uuid = "fd2e0fd5-c586-0127-4d3d-0e272a5894d2"
> > > device_model = "/usr/lib64/xen/bin/qemu-dm"
> > > kernel = "/usr/lib/xen/boot/hvmloader"
> > > vnc=1
> > > vncunused=1
> > > apic=1
> > > acpi=1
> >
> > Try toggling these last two settings here - one of the 4 different
combos
> > of acpi & apic may well help.
> >
> > Regards,
> > Dan.
> > --
> > |=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392
2496 -=|
> > |=-           Perl modules: http://search.cpan.org/~danberr/
-=|
> > |=-               Projects: http://freshmeat.net/~danielpb/
-=|
> > |=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505
-=|
>
> --
> Fedora-xen mailing list
> Fedora-xen redhat com
> https://www.redhat.com/mailman/listinfo/fedora-xen
>


-- 
David L. Parsley
Linux Systems Engineer, James Madison University
"If I have seen further, it is by standing on ye shoulders of giants"
- Isaac Newton


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]