[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-xen] fc6: xennet module issue with kickstart



Hello,

I found one more little issue to stumble over :)

I tried (among others) the following kernel:
 kernel-xen-2.6.18-1.2798.fc6.i686.rpm and the initrd from a (freshly rsynced) images/xen/ directory.

When the domU is created it comes up properly, and automatically preloads the xenvbd module,
but not xennet. I extracted the initrd and found the xennet module there, but it seems not possible
to load it from the network driver dialog (it's not listed). I'm confused as I also tried an fc5 kernel + initrd, and also
a rhel5 beta kernel+initrd. I think the issue is somewhere with the initrd, but don't really found a hook to
change anything, maybe short of rebuilding the initrd using --preload xennet

If You're successfully installing FC6 domU's from within xen, please speak up!

the following are the relevant settings from the domU configfile
kernel = "/mnt/xendistro_temp//vmlinuz"
ramdisk = "/mnt/xendistro_temp/initrd.img"
extra = "ks= http://192.168.199.4/ks_fc6.cfg"
ip = "192.168.199.5"
netmask = "255.255.255.0"
gateway = " 192.168.199.1"
# single line :)
disk = [ 'phy:/dev/evms/ll-kickme_root,hda,w',
'phy:/dev/evms/ll-kickme_rootmir,hdb,w',
'phy:/dev/evms/ll-kickme_swap,hdc,w',
'phy:/dev/evms/ll-kickme_home,hdd,w' ]
vif = [ 'type=ioemu, bridge=xenbr1' ]

Florian

--
'Sie brauchen sich um Ihre Zukunft keine Gedanken zu machen'

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]