[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] Win Xp 32 bit as guest in



Thanks for your answer,

When I pressed F5, i saw the display you're talking about (choose between different hardware infrastructure). But as someone already mentioned in another post, I was unable to use the keyboard to make a selection. So I installed the qemu package (yum install qemu.x86_64) an then install XP SP2 with qemu with the following command (for documentation):

qemu -cdrom /dev/dvd -m 512 -boot d -hda /dev/vg_domU/lv_windows

There, I was able to use my keyboard to choose an architecture (after having pressed F5...). Ichoose "Standard PC" as you suggest. Whence windows has been installed (took a looong time), I can now start my guest with xen...

I count 2 (minor?) bugs there: the bad architecture detection, and the incapacity to use the keyboard after pressing F5 on the "..preess F6.." screen

Thanks very much for your help
I now have to find a way to make my DVD Writer available to this win guest, but i read elsewhere that this is not possible, even with a full virtualized guest...it it?

David Parsley wrote:
Hi Denis,

On 11/12/06, Denis Forveille <denis forveille gmail com> wrote:
Q:
- is it possible to run an instance of Win XP SP2 32bits as a guest on a
x86_64 FC6 fully updated dom0? (CPU = AMD x2 4600 with pacifica...)

I successfully installed Win XP in an lvm logical volume. Everything
worked fine and at the end, I got the request from XP asking to remove
the CD and reboot...
Then, when I try to start the guest (after changing the line from boot=d
to boot=c in the config file), the only thing I see is a black screen.
(the windows resize itself and then a black screen...)
"xm top" shows that the guest consumes 0% CPU...
I think I've tried almost every combination of parameters in the config
files (pae, acpi,sdl...) during installation and after...
Also, I've seen that others have post similar problems in this forum,
but none of them have answers/workarounds to my problem.

Does anyone succeeded in running such a combination (ie XP SP2 32 bits
in a 64bit FC6)?
Or maybe the problems comes from the fcat that I installed windows in an
lvm instead of in a file?
Thx in advance

I had this problem, too - the solution was re-installing WinXP, and,
when the installer asks you to press 'F6' for addtional drivers, press
'F5' instead.  Then select 'Standard PC ...'

My XP VM runs in either FC6 32 or FC6 64, pretty well.  Hopefully
future versions of Xen won't require this workaround.

Regards,
David


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]