[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] X startup failure with Xen kernel



On Wed, Nov 15, 2006 at 05:31:28PM +0000, bloch verdurin com wrote:
> On a system upgraded from FC5 to FC6, I find that the whole system hangs
> at X startup if I boot with the Xen kernel.  Even Alt-SysRq has no
> effect.
> 
> X starts without any problems on a non-Xen kernel.
> 
> It's a Dell OptiPlex GX270.
> 
> lspci output:
> 
> 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated
> Graphics Controller (rev 02)

There's an issue with encountered with Xen and a number of Intel graphics
cards when testing for RHEL-5. The core problem is that the real-mode
emulation in Xen is broken, so its not handling the switches between
16&32bit mode correctly. We tried to fix Xen but the VMX assist code is just
tooo hairly to resolve correctly - a fix for one graphics card would
break a different one.  So instead, our Xorg wizards have patched the X
server to use its own built in realmode  emulation instead of relying on
Xen.

The updated 'xorg-x11-server' RPMs are being prepared for a Fedora Core 6
update in the very near future, so keep an eye on the updates-testing
YUM repository for  the fix....

Regards,
Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]