[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] xen partitioning for Vista



Andrew,

I just noticed something significant.  It is not the partition or the file causing the problem.

In my assumption I based it on the fact I used the file when using the old xen kernel 2798, and used the partition on the new xen kernel 2849

I just tested it using a file on both kernels, and it turns out that it works using a file only under the old kernel.  Using the exact same config file on the new kernel does not work.  I did not test using a partition on the old kernel, but I bet it would work.

At last I can finally continue working on this!  But, it looks like a problem that needs to be documented in the short term and fixed in the next kernel in the long term.  I hope anyone else trying this finds this!

Thanks for your assistance,

Ian Patton

On 11/27/06, Andrew Cathrow <acathrow redhat com> wrote:
See what happens if you give it a file instead of a physical partition.

Aic


On Mon, 2006-11-27 at 19:40 -0500, Ian Patton wrote:
I added a new drive to use with a fully virtualized Xen domain.  I intend to run Vista on it.  Should the partition be formatted?  If so, should it be formatted using ext3 or ntfs?  Should the Windows installer do the partitioning?  I asked this as part of a multi-part question previously an only got a partial answer excluding this....  On my system, the partition is /dev/hdc1

On my first attempt at getting Vista to work, I used a file instead of a partition and it worked.  It worked for a very short period of time.  Vista would boot and I could see the desktop.  The only thing that did not work was the network, which I was sure would be an easy fix.  I installed a few patches and some other software via Yum and at some point Vista stopped booting.  I decided to add a new 120G disk for it to use and start over, but ever since I have not been able to get it to run.  None of the logs show anything helpful.  It runs for about 5 seconds, and I can see it boot from the ISO that I made, but after it loads the progress bar to 100% it tries to change the screen resolution or something and the processor drops to 0% and nothing else happens. 

Meanwhile, i have learned a bit about using Xen and tried to help others on the list, but still have gotten nowhere with my own problems.  I will be posting a nice howto once i get all the steps and facts straight.

Thanks in advance,

Ian Patton
--
Fedora-xen mailing list
Fedora-xen redhat com
https://www.redhat.com/mailman/listinfo/fedora-xen
-- 

Andrew Cathrow
Red Hat, Inc.

(678) 733 0452 - Mobile
(404) 437 6178 - Home Office

acathrow redhat com



--
Ian Patton
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]