[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-xen] Re: virDomainCreateLinux() failed



Bill Davidsen wrote:
Daniel P. Berrange wrote:
On Fri, Nov 17, 2006 at 05:51:24PM -0500, Bill Davidsen wrote:
FC6, xen installed, latest updates as of five minutes ago. ASUS P5LD2-R2.0 board, Intel 6600 CPU, 2GB RAM, 1.5TB disk. PAE on, virtualization on. xend running, "xm list" works, shows one domain.


Install of any fully virtualized o/s fails. Sample output:
Would you like a fully virtualized guest (yes or no)? This will allow you to run unmodified operating systems. yes
How much RAM should be allocated (in megabytes)? 256
Would you like to enable graphics support? (yes or no) no


Starting install...
libvir: Xen Daemon error : GET operation failed: No such domain OpenBSD-4.0 libvir: Xen Daemon error : POST operation failed: (xend.err 'Error creating domain: Disk image does not exist: /home/davidsen/Virtual_Machines/OpenBSD-4.0a')

In FC6 GA you have to make sure the file for the disk was under /xen
to be labelled correctly. In rawhide (and the latest FC6 policy)
we're moving to /var/lib/xen/images. This is consistent with the
directory used on Suse, and what the next version of XenD will
enforce. To double check what directory is setup for the SELinux
policy you can run

  semanage fcontext -l | grep xen_image_t

If you don't have space under /var/lib/xen/images, then either
mount a new volume there, or bind that dir to a location which
has extra space, eg

    mount --bind /some/dir/with/big/disk  /var/lib/xen/images

If you really really don't want to use /var/lib/xen/images at all,
then you can define a new location in the SELinux policy using:

   semanage fcontext -a -f "" -t xen_image_t '/some/directory(/.*)?'

This sounds like the missing piece, I can check where the current install wants it, and then get it there in one way or another. I'll try it some time over the long weekend and report back.

Thanks much, I suspect this was the hint I needed.

Wasn't, unfortunately. I still get told both the ISO and the file don't exist, even though they clearly do. And after attempting a create the system eats the root filesystem so I have to reinstall. Makes for slow testing.

- works with Windows and VMware, I think that lets hardware out
- runs memtest86+ for hours (and fails every time I do an install).
- checked with semanage, /xen and /var/lib/xen/images are listed.

Can I safely resize the Dom0 down to get room to do an install?
Is it related to running LVM (don't usually).

I have a ton of captured logs and such, didn't want to post or load for www unless someone wants to see them. Same error as subject, log shows "file does not exist" even though the install process created the image file.

--
Bill Davidsen
  He was a full-time professional cat, not some moonlighting
ferret or weasel. He knew about these things.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]