[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] Slightly off-topic question about Xen+LVM


On Tue, 2007-11-20 at 13:55 -0500, Aaron Metzger wrote:

> I tried to use the system-config-lvm tool to create a snapshot of the 
> logical volume and assigned it to a mount point that I created under 
> "/mnt/vmbackups" and checked the box to have it mounted at boot time.

OK, that should work... *IF* you are careful about some of the gotchas
concerning snapshots.

Namely... if you're mounting them, be aware that the original filesystem
and its snapshot will both have the same UUID and filesystem label.  So
if you try to mount-by-label (eg. "LABEL=foo" in fstab), you can't
guarantee which one will be picked up.

Now, filesystems set up by anaconda on LVM should be specified
in /etc/fstab by their LVM path, not by their label.  But if you have
set up the fstab entry yourself by label, then you might well confuse
the system.

> When I rebooted the machine, the boot failed when It tried to access the 
> snapshot logical volume.  I'm not going to include the specific errors 
> here because my question is much more general.

Well, in general it should work.. we'd need to see the error to know if
there's a special-case you've fallen into.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]