[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-xen] Problem: mount: could not find,filesystem '/dev/root'



Hi, All:

  I got a problem (mount: could not find,filesystem '/dev/root') in booting a fedora7-xen kernel which was downloaded at http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/kernel-i686. Also I had tried fedora8-xen kernel, same problem.

  Here is my "grub.conf":

  title Fedora (2.6.21-7.fc7xen)
        root (hd0,0)
        kernel /xen.gz-2.6.21-7.fc7
        module /vmlinuz-2.6.21-7.fc7xen ro /dev/VolGroup00/LogVol00 rhgb quiet
        module /initrd-2.6.21-7.fc7xen.img

 title Fedora (2.6.27.21-170.2.56.fc10.i686.PAE)
        root (hd0,0)
        kernel /vmlinuz-2.6.27.21-170.2.56.fc10.i686.PAE ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.27.21-170.2.56.fc10.i686.PAE.img

 title Fedora (2.6.27.21-170.2.56.fc10.i686)
        root (hd0,0)
        kernel /vmlinuz-2.6.27.21-170.2.56.fc10.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.27.21-170.2.56.fc10.i686.img

  The "ro /dev/VolGroup00/LogVol00 rhgb quiet" part was the same in all the three ones, but "Fedora (2.6.27.21-170.2.56.fc10.i686.PAE)" and "Fedora (2.6.27.21-170.2.56.fc10.i686)" could  boot normally (this showed the path should be right).

  The difference between the first and the latter two was "module", but the tries:
        title Fedora (2.6.21-7.fc7xen)
        root (hd0,0)
        kernel /xen.gz-2.6.21-7.fc7 ro /dev/VolGroup00/LogVol00 rhgb quiet
        module /vmlinuz-2.6.21-7.fc7xen
        module /initrd-2.6.21-7.fc7xen.img
and
        title Fedora (2.6.21-7.fc7xen)
        root (hd0,0)
        kernel /xen.gz-2.6.21-7.fc7 ro /dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.21-7.fc7xen.img

neither worked.

  My os was Fedora 10, and xen was install by "yum install xen". What should I do for this problem??

  By the way, it seemed that "yum install kernel-xen" installed "2.6.27.21-170.2.56.fc10.i686.PAE", which did not worked. Since when I booted with this fedora-xen kernel, "xend start" command (or xm command) brought "ERROR Internal error: Could not obtain handle on privileged command interface (2 = No such file or directory)" error, which I've no idea either. (From google, someone told that it was caused by wrong kernel...)

  Any helps will be very appreciated!

Best Regards!
Xin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]