[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-xen] Fedora 11 Xen domU grub.conf timeout=0 problem with pygrub


I just installed Fedora 11 Xen PV domU on Fedora 11 Xen dom0, using virt-install
like this:

virt-install -n testvm -r 512 --vcpus=1 -f /dev/vg_dom0test/testvm --vnc -p
-l "ftp://ftp.funet.fi/pub/mirrors/fedora.redhat.com/pub/fedora/linux/releases/11/Fedora/i386/os";

Installation goes fine, but after the installation is complete, and the domU
gets rebooted, it will never come up again. I tried multiple times, and it's
always the same. Installation starts and works fine, but after installation domU
doesn't start anymore - not even after "xm destroy" and "xm start".

I started investigating the problem, and from "xm log" I noticed the last
line of output is about starting pygrub and nothing after that.

I checked "ps aux" and noticed pygrub is there, waiting for something.
"strace -p" shows it's waiting for something, and checking the status all the time.

I tried running the same pygrub command from cmdline, and noticed I have to
press enter before the kernel gets chosen by pygrub. After pressing enter pygrub
copies the kernel/initrd/configuration and exists OK.

I echoed the config from manual pygrub run to /var/run/xend/boot/xenbl.pid file, 
killed pygrub, and after that the after-installation-reboot continued normally..

When the domU got up I checked grub.conf from it:

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_f11domu-lv_root
#          initrd /initrd-version.img
title Fedora (
        root (hd0,0)
        kernel /vmlinuz- ro
        root=/dev/mapper/vg_f11domu-lv_root rhgb quiet
        initrd /initrd-

timeout=0 looks suspicious.. so I changed it to 5. 
After that domU comes up OK on its own..

I changed timeout back to 0, and pygrub gets stuck again.

Is this a bug of pygrub, or a broken default grub.conf timeout value of F11?

-- Pasi

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]