[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Freeipa-users] version mismatch while joining a client ?



Steven Jones wrote:

Yes....enrolement now fails, previous messages I attached show that I think, it used to work.

History, I had to remove all my working IPA clients due to a disk space problem on our SAN (we didnt have any).  So I managed to keep the working IPA server and 2 x RHEL5 64 bit servers and the one un-configured template of RHEL6.1 64bit client I had. This I used to make client side clones off previously and connected them to IPA server and they worked.

So lastweek I went back and with a running ipa server, I cloned in the old client/template and got the mis-match, so I put them on the production network and patched, same mismatch problem.

I can do a sosreport of the old template I think and the client to look at the differences if that helps.

I'm having a hard time following exactly what you are doing, on what machine. I think we need to be more systematic.

Can you choose a machine to act as the client and provide the following:

- distro and architecture (e.g. RHEL 6.1 on x86_64)
- rpm -q curl libcurl
- rpm -q ipa-client

On the IPA server:
- rpm -q ipa-server

Start with a client that is not enrolled. If it has previously been enrolled run: ipa-client-install --uninstall -U

Now run ipa-client-install and answer the questions as appropriate for your install.

If it fails please provide the following:
- any stdout you get from the client install
- attach the full /var/log/ipaclient-install.log
- attach the last 100 lines from /var/log/httpd/error_log from the IPA server

rob


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]