[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Freeipa-users] Unable to start IPA server after server reboot



Ondrej Valousek wrote:
  Hi Rob,
It was just "polaris" - so I tried:
[root polaris etc]# hostname polaris.example.com

and it started working - Magic!
That means that we rely on the fact that hostname is set to FQDN, right?
Isn't it too strong requirement?
Maybe we should guess FQDN using reverse lookups I do not know. The
bottom line is that at least the IPA installation script should warn
about the incorrect hostname.

And the error message was bit confusing as well, because from that one
none can even guess what went wrong, I even tried to add 'ipactl -d
start' to print more debugging, but it did not help either.

Just trying to bring some ideas, otherwise I am happy that it is working
again for me :-)
Thanks!

Ondrej

Kerberos and SSL really want fully-qualified names.

We've done some upstream work to address detecting when the hostname is not a fqdn. I filed a new ticket for the poor error message.

thanks for the suggestions.

rob


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]