[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Freeipa-users] Post installation ( looks to be small issue )..



Nigel Sollars wrote:
Hi all,

After fixing upa number of things and successfully installing / testing
the server install,  I have a small issue with the UI inside firefox in
that after importing the CA and looking at a few guides I notice these
line in my http error logs:

What things did you fix up?


[Thu Jan 19 13:17:56 2012] [error] [client x.x.x.x] File does not exist:
/usr/share/ipa/ui/develop.js, referer:
https://ipaserver.jitscaleus.net/ipa/ui/
[Thu Jan 19 13:19:41 2012] [error] [client x.x.x.x] File does not exist:
/usr/share/ipa/ui/develop.js, referer:
https://ipaserver.jitscaleus.net/ipa/ui/
[Thu Jan 19 13:19:59 2012] [error] [client x.x.x.x] File does not exist:
/usr/share/ipa/ui/develop.js, referer:
https://ipaserver.jitscaleus.net/ipa/ui/
[Thu Jan 19 13:27:58 2012] [error] [client x.x.3.x] File does not exist:
/usr/share/ipa/ui/develop.js, referer:
https://ipaserver.jitscaleus.net/ipa/ui/
[Thu Jan 19 13:31:34 2012] [error] [client x.x.x.x] File does not exist:
/usr/share/ipa/ui/develop.js, referer:
https://ipaserver.jitscaleus.net/ipa/ui/

I think this can be ignored, I believe the code is just used for testing/developing (and isn't used at all in newer builds).

I ran through the trouble shooting guide with re-running kinit ( passing
password ) then running, ldapsearch -Y GSSAPI -b "dc=domain,dc=com"
uid=admin, which returned the correct response,

The browser loops around the configuration from the server to return to
the webui with the error of an invalid ticket.

Did you configure the browser to do negotiate authentication (or use the configure firefox button)?

I am not 100% if this is relevant or not but the client install that was
called after the ser install finalized, bombed completely with the folowing:

Traceback (most recent call last):
   File "/usr/sbin/ipa-client-install", line 1292, in <module>
     sys.exit(main())
   File "/usr/sbin/ipa-client-install", line 1279, in main
     rval = install(options, env, fstore, statestore)
   File "/usr/sbin/ipa-client-install", line 1117, in install
     fstore.backup_file("/etc/sssd/sssd.conf")
   File "/usr/lib/python2.6/site-packages/ipapython/sysrestore.py", line
126, in backup_file
     shutil.copy2(path, backup_path)
   File "/usr/lib64/python2.6/shutil.py", line 95, in copy2
     copyfile(src, dst)
   File "/usr/lib64/python2.6/shutil.py", line 51, in copyfile
     with open(dst, 'wb') as fdst:
IOError: [Errno 2] No such file or directory:
'/var/lib/ipa-client/sysrestore/107a99f6a6514e30-sssd.conf'

Strange. Does /var/lib/ipa-client/sysrestore exist?

rob


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]