[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Freeipa-users] ipa host-del



On Wed, 2012-09-05 at 15:41 -0400, John Dennis wrote:
> On 09/05/2012 02:40 PM, george he wrote:
> > Thanks a lot. It's deleted now!
> > The .jar thing (i.e. jss4.jar, osutil.jar, and symkey.jar) was pointing
> > to /usr/lib/..., but when I was struggling, I read on the web there was
> > a post saying they should point to /usr/lib64/..., so I changed them.
> > The weird thing is I THINK they were pointing to existing files, but now
> > they are not.
> > So I changed the links one more times to make them pointing to
> > /usr/lib/..., restarted ipa, and host-del worked.
> > Thanks again, guys.
> > George
> 
> Glad it's working. Obviously we would like to know how you got into this 
> situation and perhaps open a bug. But unfortunately since you've 
> manually changed links it's hard to know if the logic used to update an 
> existing system is robust or not. I recall when the issue of where to 
> locate native jars on 64bit came up there was a fair amount of back and 
> forth over where things would be installed and which links to introduce. 
> Unfortunately I do not recall the final resolution, it might be that the 
> tomcat instances were supposed to continue to point to /usr/lib/java and 
> links would be set up there to point to the 64bit version. In any event 
> I don't think we can file a bug at this point, but perhaps we need to 
> pay attention and see if anyone else gets bitten by this.

I just recently had to fix this for my 'stable' install too, seem like
we need to do better on upgrades going forward.

Simo.

-- 
Simo Sorce * Red Hat, Inc * New York


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]