[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2011:0211-01] Important: jbossweb security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: jbossweb security update
Advisory ID:       RHSA-2011:0211-01
Product:           JBoss Enterprise Web Platform
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2011-0211.html
Issue date:        2011-02-10
CVE Names:         CVE-2010-4476 
=====================================================================

1. Summary:

Updated jbossweb packages that fix one security issue are now available for
JBoss Enterprise Web Platform 5 for Red Hat Enterprise Linux 4 and 5.

The Red Hat Security Response Team has rated this update as having
important security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from the
CVE link in the References section.

2. Relevant releases/architectures:

JBoss Enterprise Web Platform 5 for RHEL 4 AS - noarch
JBoss Enterprise Web Platform 5 for RHEL 4 ES - noarch
JBoss Enterprise Web Platform 5 for RHEL 5 Server - noarch

3. Description:

JBoss Web Server is a web container based on Apache Tomcat. It provides a
single deployment platform for the JavaServer Pages (JSP) and Java Servlet
technologies.

A denial of service flaw was found in the way certain strings were
converted to Double objects. A remote attacker could use this flaw to cause
JBoss Web Server to hang via a specially-crafted HTTP request.
(CVE-2010-4476)

Users of JBoss Web Server should upgrade to these updated packages, which
contain a backported patch to correct this issue. The JBoss server process
must be restarted for this update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

674336 - CVE-2010-4476 JDK Double.parseDouble Denial-Of-Service

6. Package List:

JBoss Enterprise Web Platform 5 for RHEL 4 AS:

Source:
jbossweb-2.1.10-5.patch01.1.ep5.el4.src.rpm

noarch:
jbossweb-2.1.10-5.patch01.1.ep5.el4.noarch.rpm
jbossweb-jsp-2.1-api-2.1.10-5.patch01.1.ep5.el4.noarch.rpm
jbossweb-lib-2.1.10-5.patch01.1.ep5.el4.noarch.rpm
jbossweb-servlet-2.5-api-2.1.10-5.patch01.1.ep5.el4.noarch.rpm

JBoss Enterprise Web Platform 5 for RHEL 4 ES:

Source:
jbossweb-2.1.10-5.patch01.1.ep5.el4.src.rpm

noarch:
jbossweb-2.1.10-5.patch01.1.ep5.el4.noarch.rpm
jbossweb-jsp-2.1-api-2.1.10-5.patch01.1.ep5.el4.noarch.rpm
jbossweb-lib-2.1.10-5.patch01.1.ep5.el4.noarch.rpm
jbossweb-servlet-2.5-api-2.1.10-5.patch01.1.ep5.el4.noarch.rpm

JBoss Enterprise Web Platform 5 for RHEL 5 Server:

Source:
jbossweb-2.1.10-5.patch01.1.1.ep5.el5.src.rpm

noarch:
jbossweb-2.1.10-5.patch01.1.1.ep5.el5.noarch.rpm
jbossweb-jsp-2.1-api-2.1.10-5.patch01.1.1.ep5.el5.noarch.rpm
jbossweb-lib-2.1.10-5.patch01.1.1.ep5.el5.noarch.rpm
jbossweb-servlet-2.5-api-2.1.10-5.patch01.1.1.ep5.el5.noarch.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-4476.html
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert redhat com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2011 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFNVEChXlSAg2UNWIIRAqECAJ996q2H9Ft6YWVUSgfcryt38nSW1gCfb8z6
3iJwSU2YUgb5TdQiWEPMZ00=
=U+y2
-----END PGP SIGNATURE-----



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]