[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] squidguard gives errors



Dear Listers,
	i am trying to implement squidguard. i've set the firewall to
point to the proxy server (no user setup needed!) and the offending sites
get redirected to the "work" site - no nasty messages, no discussion. the
problem is, it works only every other time. the first time i point to
playboy.com, i get the site redirect option specifies, the second time i
try playboy.com i get:

ERROR
The requested URL could not be retrieved
While trying to retrieve the URL: /
The following error was encountered:
    * Invalid URL
Some aspect of the requested URL is incorrect. Possible problems:
    * Missing or incorrect access protocol (should be `http://'' or similar)
    * Missing hostname
    * Illegal double-escape in the URL-Path
    * Illegal character in hostname; underscores are not allowed
Your cache administrator is root.
Generated Tue, 16 Apr 2002 12:47:04 GMT by octopuss (Squid/2.4.STABLE3)

then i get the redirected site and then i start getting the naughty site
because the firewall can't get an answer from the squid server.

the server is a pii450 with 192mb memory (it was handy, ok?), running rh72
from k12 2.0.2 distribution. the squid.conf has http access changed to
"allow all", http port 80 added and at the end:

        redirect_program /usr/sbin/squidGuard -c /etc/squid/squidGuard.conf
        redirect_children 5

squidGuard.conf has the following:
 redirect     302:http://www.turtle.com/

did i miss something very obvious? do i need a lot more redirect_children?
tia, julius





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]