[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] up2date problem



On Tuesday 13 January 2004 05:10, Randall Swift wrote:
> I have tried to update the server (k12ltsp 4) using up2date.
> The process works for a while and stops at the "Fetching rpm
> header: glibc-2.3.2-101.4". I have tried this nemerous times
> and the same thing always happens. Any thuoghts? Thanks

I've been having problems with up2date for about a week now.  This 
is fortuitious for me because I'm covering update strategies in 
tomorrow's Linux sysadmin class. 

It appears to me that this problem is being caused by servers at 
RedHat becoming overloaded with update requests.  Hopefully the 
system will still be failing tomorrow so I can give my students a 
real-world exercise in what to do when this happens!

Here's what I'm going to teach them:

1st, explain how up2date works.

2nd, show them how to use yum from a command line (not much better 
because it still tries to retrieve updates from the same servers)

3rd, teach the art of going to a nearby mirror, download the 
updates manually, and apply them manually with the RPM command.

I tell you, when students come out of one of MY classes, they are 
By God PREPARED! 

Ken
-- 
"..it does not require a majority to prevail, but rather an irate, 
tireless minority keen to set brush fires in people's minds.."
	-- Samuel Adams





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]