[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Still having local printing issue



Hello everyone, I apologize for emailing once more, but I am still having an issue adding a printer to a terminal system.

A bit of background:

I have two identical hardware setups for K12LTSP 4.0. I made a duplicate of my original K12LTSP to the second which I intend to use at a different office. With that said, I did change the IP addresses of both NICs in the system.

I am trying to setup a local HP Deskjet 842c printer on a generic PC that has an Intel CA810E motherboard and 3Com NIC. I am able to add the printer through the Fedora printer configuration applet as a JetDirect pointing to the IP of the computer, which I have mapped to the MAC address in dhcpd.conf. However, when I attempt the CUPS test print, nothing happens. The printer status reads - "Network host '192.168.0.154' busy: will try again in X seconds." I am dual booting the system, and I can print to the local printer through Windows.

On the original system I had a similar message about a year ago - I changed my lts.conf from:
[ws154]
~ Actual MAC Address ~
PRINTER_0_DEVICE = /dev/lp0
PRINTER_0_TYPE = P


to:
[ws154]
PRINTER_0_DEVICE = /dev/lp0
PRINTER_0_TYPE = P

This change solved the issue on the original system.

I tried this on the second system with and without the MAC address section. Neither helped. I updated the system BIOS and changed the printer port from Bi-directional to ECP. Did not help either.

The last time I tried I did say that the test print failed and I was given an error log:
- Adding start banner page "none" to job 1489
- Adding end banner page "non" to job 1489
- Job 1489 queued on 'DJ842C' by 'root'
- Started filter /usr/lib/cups/filter/pstops (PID 28105) for job 1489
- Started filter /usr/lib/cups/filter/foomatic-rip (PID 28106) for job 1489
- Started backend /usr/lib/cups/backend/socket (PID 28107) for job 1489


The original system works correctly with no issues. The second (which is having the above problem) I have added an actual HP JetDirect print queue which works correctly as well.

Any advice would be greatly appreciated,

Thanks,

Michael


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]