[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] More on SchoolBell



Selzler, Bruce wrote:
> Hello Team,
> I have two questions.  First, I just updated a LTSP server via yum so
that I can
> boot iMacs from the server.  On the test iMac, its one of the blue
bondi's, it
> actually starts to boot then comes up with the following error;
> ERROR! Failed to mount the root directory via NFS!
> I'm assuming this is whats keeping the system from booting altogether.
However
> it appears that NFS is running correctly.  Any ideas?

Make sure that the ppc directory is exported. You should see a line like
this in /etc/exports:
/opt/ltsp/ppc  192.168.0.0/255.255.255.0(ro,no_root_squash,sync)
If you don't see a "/opt/ltsp/ppc" line, you can either add that line by
hand or run (if you have a stock install)
/opt/ltsp/templates/k12linux/setup-update.sh
Afterwards, run:
exportfs -a
That should do it.

[Selzler, Bruce] 
This worked great!  Thank you.  The line was already in the file so I'm
not understanding why it didn't work in the first place, but running
"exportfs -a" solved the problem.  Thanks.
[Selzler, Bruce]

> Second, I have another server, which happens to be identical to the
one justdiscussed, that I updated so I can work with the schoolbell
program.  Whileschoolbell was installed and works on the first server,
it does not on thesecond server.  And, as I said, these are identical
servers and configurations.
> Any ideas?

What does the logs say?  /var/log/schoolbell

[Selzler, Bruce] 
The problem is that there is no schoolbell log.  Even though Yum is
reporting that its installed.  Any ideas?
[Selzler, Bruce] 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]