[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] _X11TransSocketINETConnect: Can't get address for ws253.ltsp



Hi Folks,

Ok, now I've got a really weird one.

I'm trying to get SimCity 3000 Unlimited running on my new k12ltsp server. I had it running fine on my old server using "LD_ASSUME_KERNEL=2.2.5 /usr/local/games/sc3u" and a patch for sc3u from lokigames.com. Anyway, much googling led me to a workaround to get it to work under FC 5. I needed to download some old FC3 libraries and put them in a folder, then invoke the new libraries by invoking SimCity (sc3u) using a script file.
Here's the script:
~~~~~~~~~~~~~~~~~~~~~~~
COMPAT=/usr/local/games/SC3U/loki_compat/

export LD_LIBRARY_PATH=$COMPAT
LD_ASSUME_KERNEL=2.2.5 $COMPAT/ld-linux.so.2 /usr/local/games/SC3U/sc3u
~~~~~~~~~~~~~~~~~~~~~~~

I'm calling the script from a launcher (or command line) via "sh /usr/local/games/SC3U/sc3u-compat.sh". So, anyway it was working perfectly on the server console. Looked better than ever. But I go to try it on the client and *nothing* happens. I tried invoking the script from the command line (which worked on the server) and I get the following error.
~~~~~~~~~~~~~~~~~~~~~~~~
_X11TransSocketINETConnect: Can't get address for ws253.ltsp
Graphic System: Could not init SDL: No available video device
Check your DISPLAY environment variable
~~~~~~~~~~~~~~~~~~~~~~~~

This looks like a DNS issue, (or maybe an lts.conf) but I don't know what to tweak in the DNS to provide display info to the game. I'm dead in the water. Google didn't have anything for me. Any ideas how to get around this? I'm so close. I probably put in 3 hours getting SimCity working on the server. Oh, by the way GCompris, Wesnoth, tuxpaint, all work on all clients some fullscreen, some windowed. (Thanks Eric!)
Thanks,

ck


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]