[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Stuck User



Carl-

>From your description, its hard to tell if you recreated the same *uids*
and are having trouble or not.

A few points:

1.  The gnome and gconf directories in ~/ don't get created until the
first time you log into a gnome session.  They don't come from /etc/skel

2.  When recreating users, be sure you recreate usernames with the
*same* uid as they had before.  Linux really only cares about uids and
gids (ie, numbers like 1000 or 1001) and then maps usernames (bob,
frank) to those numbers.  "bob" with uid 1000 is not the same user as
bob with uid 1001. 

3.  If you recreate usernames with different uids, be sure to:
 chown -R <username>.<username> /home/<username>

Also, be sure to delete the directories and files in the /tmp directory,
as many are created with names like "virtual-<username>", and your new
username with the different uid will get confused.

4.  Many times I have seen "stuck" sessions in Gnome because of hung
gconfd-2 processes that never died from previous sessions.  Killing that
process usually "unsticks" things.  

Good luck,

-Gadi

On Mon, 2006-10-16 at 15:33 -0500, Petre Scheie wrote:
> Check the /tmp directory for leftover files tied to that user.  I had a similar problem 
> on a machine this past weekend where a test user ID was having troubles.  I deleted the 
> ID, recreated it, but still had problems with Gnome.  Turned out there were files in 
> /tmp that had the user ID in the file name that were causing problems.  Cleaned out /tmp 
> and everything was fine.
> 
> Petre
> 
> Carl Keil wrote:
> > Hi Group,
> > 
> > I had to ditch my /home drive for the time being because it has bad 
> > sectors.  So, I removed the drive and reformatted it thinking I could 
> > just recreate my users.  Now when I add a certain user (that existed 
> > before) her screen comes up completely blank when she logs in, with all 
> > kinds of Gnome errors.  When I look into her /home folder it only has a 
> > .kde directory and a few .files nothing like new users (created after 
> > the drive swap) that have a .kde .gnome, etc., etc. files and folders in 
> > their /home directories.
> > So, how do I completely get these old users out of the system so I can 
> > start over.  I tried System->Administration->Users and Groups and I 
> > tried userdel -r <username> from the command line.   (and I've tried 
> > Google)  Both of these delete the user from /etc/shadow and remove the 
> > /home directory.  But when I recreate the user her /home directory is 
> > missing most of the stuff.  I've never seen this before, but I'm sure 
> > somebody has a one liner fix for this.
> > 
> > Thanks in advance.
> > 
> > ck
> > 
> > _______________________________________________
> > K12OSN mailing list
> > K12OSN redhat com
> > https://www.redhat.com/mailman/listinfo/k12osn
> > For more info see <http://www.k12os.org>
> > 
> 
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
-- 
--------------------------------------------------------
Gideon Romm | Proud LTSP Developer
ltsp symbio-technologies com

Support LTSP!  Buy your hardware at:

        www.DisklessWorkstations.com
        www.DisklessThinClients.com 
 
(use coupon code: LTSP5P for 5% off thin clients from DisklessThinClients.com)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]