[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Mounting Windows homedirs



I have a test K12LTSP  version 6 server setup.  I have joined the AD domain and configured pam_mount to mount a Student folder on each users Desktop.  The Student folder is a Windows share on a Win2K server.  In that folder are directories for each graduating year.  The actual student home directories are in the appropriate year.

I can browse the network to the server and open the share.  Accessing it this way, I can see all the year directories and open them to see the student folders.  If I try to open a student folder without permissions, I shows empty.

When I open the folder automatically mounted on the Desktop, it just shows empty!

The pam_mount.conf file has the line:

volume * cifs HighDC Student /home/DPSD/&/Desktop/Student uid=&,gid=&,dmask=0750,workgroup=DEERPARK.WEDNET.EDU - -

to mount the folder.  The Student folder show on the Desktop, but as I said, it is empty.  There is no change if I use file types of smb or smbfs.  I even tried a dmask of 0777 with no luck.

This might be related.  If I open a terminal screen on the server as root, I get good results from all the wbinfo commands I have tried.  When I try getent passwd or getent group, I just get the local information.  My nsswitch.conf file has:

passwd    files   winbind
#shadow    files  winbind
group       files   winbind

I have tried replacing "files" with compat.  It had no effect.  I added the # to comment out the shadow line,  No good.

Any help would be greatly appreciated!  Thanks.


Steve Krause, CNE
Network Manager
Deer Park School District #414
Deer Park, WA
(509) 464-5567
krauses deerpark wednet edu



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]