[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] ldap will not start on server



Thanks for the help everyone.  Turns out that the tech coord was mis-typing the chown command, thus the *db* files weren't being reset properly to be owned by ldap. Once he noticed this, and correctly set ownership of /var/lib/ldap to ldap.ldap, everything started up properly.  I have now found that it is very difficult to troubleshoot typos. :)

I do have backups running nightly for the database, but trying to walk the tech coord through the steps via the phone when he is being pressured by teachers/etc is not a fun thing.  I wouldn't have an issue with resetting the database from the backups, but not something I want to try remotely just yet.

Anyhow, thanks! thanks! Now, I can get back to my vacation. 

Sincerely,
Dave Hopkins


On 2/15/07, David Trask < dtrask vcsvikings org> wrote:
Have you been backing up your ldap database?  If so go to the
smbldap_installer support site and read about disaster recovery
http://www.vcsvikings.org/docuwiki/cgi-bin/moin.cgi/


"Support list for open source software in schools." < k12osn redhat com>
writes:
>I go on vacation, so of course the server has problems :)
>
>The linux server used for ldap authentication crashed yesterday.  Now,
>ldap will not start successfully.  This means that samba will not start
>and that means users can' t log onto the windows servers..  Also, I have
>a slave ldap server running and we are currently authenticating against
>that server for the linux logins.  However, my windows terminal servers
>want to use the main authentication server.
>
>So, I had the tech coordinator try running the following.
>
>sladp_db_recover -v -h /var/lib/ldap
>
>but this does not correct the issue since then running
>
>/etc/init.d/ldap start will not start ldap.  It returns a message that
>slapd failed to start.
>
>The tech director is now trying:
>
>slapd_db_recover -v -h /var/lib/ldap
>chown -R ldap.ldap /var/lib/ldap
>/etc/init.d/ldap start
>
>but I am not overly optimistic.  So, the question:
>
>Can I just delete all of the db.001, db.0002, etc files and have slapd
>rebuild them without losing the database?  Then, I can run the above
>commands again?  Finally, there is a replog.lck file which I had him
>delete (it was size zero), but this had not effect on ldap starting.
>
>Sincerely,
>Dave Hopkins
>
>_______________________________________________
>K12OSN mailing list
>K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
>For more info see <http://www.k12os.org>



David N. Trask
Technology Teacher/Director
Vassalboro Community School
dtrask vcsvikings org
(207)923-3100


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]