[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Re: fl_teachertool can't broadcast on k12 6



Yes, vnc-reflector-1.2.4-3.fc6 is installed, according to rpm. Any other ideas? The error message suggests that the clients are refusing the connection. During the broadcast, a new login window and session are created; perhaps the error is about establishing that vnc session to the server rather than the vnc sessions to the clients?

Petre

Robert Arkiletian wrote:
On 2/18/07, Peter Scheie <petre maltzen net> wrote:
fl_teachertool 0.41 on my K12LTSP 6 system can't broadcast to clients.
Monitoring works, as does lock (invoke screensaver).  I've enabled
X4_MODULE_02 = vnc in lts.conf and rebooted the clients. This happens
whether I run it as root or as a user who's been given permission via
sudoers.  When I call fl_tt from a command line and try to broadcast, I
see errors like this:

/usr/sbin/teachertool-vncviewer: ConnetctToTcpAddr: connect: Connection
refused
Unable to connect to VNC server

If I run nmap against a client, it shows there is a listener on port
5900.  I copied the .vnc directory from root's home directory to
/opt/ltsp/i386/root/.  I'm stumped as to why the connections are being
refused.  Anyone have any ideas?


Copying .vnc dir to /opt tree is for Control/Monitor. For broadcast
you need two other packages.

teachertool-tightvnc (which it looks like you already have)
vncreflector (I noticed Eric has named it vnc-reflector in 6.0 repo)

make sure you have installed these.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]