[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] can't launch 'sudo /usr/sbin/fl_teachertool' via desktop icon



I don't think it's necessary, either. I made numerous changes and tweaks late last night (IOW, I was tired and groggy), including changes to the sudoers file--I think I had had some mistakes in there because when I trimmed it back, some things started working. This morning I changed the group to 'teachers', of which my ID is a member, on fl_teachertool, tried my icon, and no joy. Then discovered my icon was calling 'sudo xclock' as part of an earlier debugging effort. Changed it to call 'sudo /usr/sbin/fl_teachertool' and it worked! Then I changed the group back to root, as it originally was, and it still works. So, I'm not sure why it wasn't working for me originally and I don't know exactly what I did to fix it. I do know that compiling my own vncreflector, as mentioned in another thread, was key to getting Broadcast to work. But I don't think that has anything to do with why I could not get fl_teachertool to launch via an icon.

Petre

Robert Arkiletian wrote:
On 2/20/07, Nadav Kavalerchik <nadavkav gmail com> wrote:
i've had the same issue,
try setting Group or Others execute permission bit on the file
/usr/sbin/fl_teachertool
( i think that should do it )

This is odd, why should allowing others or group execute bit matter if
it's being run as root. My makefile sets the permissions to 754. If by
using sudo it's being run as root there should be no problem.
Sometimes I forget to put sudo in front of the fl_teachertool command.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]