[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] yum update fails



Eric Harrison wrote:
Eric Harrison wrote:
Petre Scheie wrote:
Thanks for that.  I notice my K12LTSP 5 (FC5) server is now having the
same problem. Using the exclude command works, but why is this problem
arising now?  Was the K12LTSP repo previously in sync with the Extras
repo, but is no longer?

Petre

I noticed this one on some of my boxes as well.  Icewm was just added to
extras, it was not included previously.

I'll update the K12LTSP packages so that they don't conflict...

-Eric


New IceWM packages for K12LTSP 5.0 32/64bit and K12LTSP 6.0 32bit have
been uploaded  (hopefully 6.0 64bit later in the day).

The repositories are rebuilding right now, should be done within a half
hour...

-Eric

'yum update' works just fine now, including Extras. Thanks Eric. You're two for two today!

Petre

wilson wilsonch gotdns com wrote:
Just disable the icewm package in yum for the Extra's repo. Goto your
/etc/yum.repos.d/ and edit the Extra's repo file and add the exclude
command. :)


exclude=icewm


Wilson


More info: It appears to be a conflict between the k12lstp repo and the
extras repo.  K12ltsp uses icewm-* version 1.2.28, which is what is
installed; and the extras repo has icewm-* version 1.2.30.  I disabled
the extras repo (yes, there's a way to do it on the commandline passed
to yum, but I can never remember the syntax) and then 'yum update' ran
fine.  But I'd rather not have to turn off the extras repo whenever I do
an update.  Is this normal?

Petre

Petre Scheie wrote:
Just installed k12lstp 6, and am trying to run yum update.  It fails
with this error:

--> Processing Dependency: icewm = 1.2.28 for package: icewm-l10n
--> Finished Dependency Resolution
Error: Missing Dependency: icewm = 1.2.28 is needed by package
icewm-l10n

But icewm is installed (by default):

# rpm -qa |grep ice
icewm-menu-gnome2-1.2.28-1.k12ltsp.6.0.0
icewm-1.2.28-1.k12ltsp.6.0.0
icewm-themes-1.2.28-1.k12ltsp.6.0.0
icewm-l10n-1.2.28-1.k12ltsp.6.0.0

I deleted the /var/lib/rpm/__db* files and ran 'rpm --rebuilddb',
but it
made no difference.  Any suggestions?

Petre


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]