[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] OOo default save format



Michael Blinn wrote:
After upgrading to K12v6 my OOo defaults to saving as .odt, not .doc (word97). I re-ran the script at /opt/ltsp/templates/k12ltsp/openoffice-ms-format-defaults.sh however this didn't work. Examining the script I found that the patches are looking for .xcu files in /usr/lib/openoffice.org2.0/share/registry/modules/org/openoffice/Setup however the file in there are:

-r--r--r-- 1 root root 1636 Feb 20 09:51 Setup-calc.xcu.orig
-r--r--r-- 1 root root  598 May 11 13:55 Setup-calc.xcu.rej
-r--r--r-- 1 root root 1669 Feb 20 09:51 Setup-impress.xcu.orig
-r--r--r-- 1 root root  646 May 11 13:55 Setup-impress.xcu.rej
-r--r--r-- 1 root root 4161 May 29 15:43 Setup-writer.xcu.orig
-r--r--r-- 1 root root  607 May 11 13:55 Setup-writer.xcu.rej

The .rej are the patch rejects. - I removed the .orig from the .xcu files, then deleted the .rej, and re-ran the script. Though the patches applied cleanly and the defaults are set in the .xcu files to 'MS Word 97', OOo still saves as .odt -- Has something changed in the move up to OOo 2.0.4 or am I screwing something up with my manual fiddling?

Thanks,
 Michael


Interesting. I just checked the K12LTSPv6 box I have at home and it works just fine.

Note that if you run the openoffice-ms-format-defaults.sh script more than once, it will generate the *.rej files (it cannot patch an already patched file). The *.rej files themselves are not necessarily an indicator of a problem.

One way to check that they were patched correctly is to cd to the directory and run diff on the files:

# cd /usr/lib/openoffice.org2.0/share/registry/modules/org/openoffice/Setup
#  diff -u Setup-writer.xcu.orig Setup-writer.xcu
--- Setup-writer.xcu.orig       2007-04-17 10:47:17.000000000 -0700
+++ Setup-writer.xcu    2007-05-29 22:03:06.000000000 -0700
@@ -48,7 +48,7 @@
           <value>writer8_template</value>
         </prop>
         <prop oor:name="ooSetupFactoryDefaultFilter">
-          <value>writer8</value>
+          <value>MS Word 97</value>
         </prop>
         <prop oor:name="ooSetupFactoryEmptyDocumentURL">
           <value>private:factory/swriter</value>


If you see the same output, the openoffice-ms-format-defaults.sh script did indeed change default format from odt to doc.

Note that this sets the DEFAULT format. Users can change their own settings. Changing the default settings has no effect on personal settings. When I am testing the default settings, I just rename (or totally nuke) my ~/ .openoffice.org2.0 directory - the next time your run an OO.o app it will use all of the default settings (you'll lose all of your custom settings, of course ;-)

Oh, and just to make sure this is not a versioning issue, I'm using the openoffice.org 2.0.4-5.5.22 packages and the ltsp_config 0.0.41-k12ltsp.6.0.0 package.

-Eric


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]