[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Sky high load average with FF and CentOS?



All,

Thanks for the suggestions.  Thursday and Friday I had a chance to
stress test the server.  What I did was log into the 32 systems in the
Tech Lab and then I used TeacherTool to automatically launch FF3 on
all the logged in accounts against different sites.  I also launched
quite a few other packages as well.  FF3 (with its plugins) by itself
would drive the load average way up, and also kept the %idle time on
the server near zero.  This made the system very sluggish.  Following
Terrell's instructions, I installed FF2 instead along with all of the
same plug-ins that FF3 had installed.  Launching FF2 the same way also
spiked the load average but the big difference is that after the
initial launch, the load average dropped back down to something very
reasonable, and the %idle stayed at around 30% (or so).  The system
stayed responsive to user input, and didn't appear to be hanging or
sluggish.  I had downgraded the flash plugin to the .48 version
instead of the latest version  for both FF3 and FF2.  Final note: The
systems have enough memory that swap was never used in any of the
testing.

Reports from the Tech Dir said the system had also hung when teachers
looked at pdf files. So, I launched acroread for 8 accounts.  The load
average immediately jumped sky high, and the acroread processes
continuously consumed 70% plus of the cpu each.  %idle went to 0, and
stayed there.  Not sure about exactly what this means except it is
very repeatable. Using acroread (or the nppdf.so plugin) causes
issues.  I looked around to try and locate xpdf in a yum repository to
use instead, but didn't find it.  I'll try and install from downloaded
rpm's instead.  I am seriously thinking about using one of my servers
as an application server and just setting up some of the 'problem'
apps to load from it via a ssh session.  At least that way the LTS
server should stay responsive. I just don't think I can get the
plug-ins to behave the same way so it might not work, especially as I
need sound to work as well.

I am going back into the school today to make sure that all my servers
are now 'identical' at CentOS 5. with the same apps and such.  I need
to add a second ethernet connection for the authentication servers
using 'bond with fail-over' to make sure they stay online.  And I need
to get transparent proxying working since I have a few Windows-based
PC's that have to boot from the thin client network. (either that or
find a way to run a new line through a concrete floor) :)

Again, thanks for all the help.

Sincerely,
Dave Hopkins


On Sat, Aug 23, 2008 at 9:38 AM, James P. Kinney III
<jkinney localnetsolutions com> wrote:
> Hi William!
>
> Try installing adblock at the proxy filter instead.
> http://notes.ozmonet.com/index.php?title=Network-Wide_Adblock
> This will use the adblock filter list and squid/squidguard to block the
> adds for the network.
>
> I may have to look at making that a default plugin for squidguard
> installs :-)
>
> On Fri, 2008-08-22 at 12:35 -0400, William Fragakis wrote:
>> Hi,
>> FF3 under certain situations can devote a decent amount of cpu when the
>> history sidebar is open.
>>
>> Also, if anyone knows how to install the adblock plugin across all the
>> users, that'd be helpful in cutting down flash ads and unnecessary
>> graphics.
>> Regards,
>> William
>>
>> On Fri, 2008-08-22 at 12:00 -0400, k12osn-request redhat com wrote:
>> > Message: 2
>> > Date: Thu, 21 Aug 2008 13:20:42 -0400
>> > From: "David Hopkins" <dahopkins429 gmail com>
>> > Subject: [K12OSN] Sky high load average with FF and CentOS?
>> > To: "Support list for open source software in schools."
>> >         <k12osn redhat com>
>> > Message-ID:
>> >         <bad371bd0808211020s308fd38fx931e7f66845e1a84 mail gmail com>
>> > Content-Type: text/plain; charset=ISO-8859-1
>> >
>> > An interesting (some might say irrititating) problem.  Rebuilt a
>> > server with CentOS EL5, upgraded to 5.2  Users are running FF3, Adobe
>> > Acrobat Reader, and StarOffice.  Things work well until reach around
>> > 28 users. Then, it just crawls and the load  average shoots up to 20+
>> > (this is a 4 processor box with 15Krpm SCSI drives in a RAID 1, home
>> > directories are on a dedicated file server).  It was running FC6 with
>> > 40+ users without issues last year, but I decided to move to CentOS.
>> > I have no idea why the system would suddenly become so unresponsive.
>> > I want to 'guess' that it is FF related, especially based on the
>> > google searches concerning FF3 and performance.  Also, FF is using is
>> > using 50%+ of the cpu per user.   I have to admit that I am rather
>> > upset at the moment with FF3, and when I tried the simple approach to
>> > untarring a build of FF2, I get all sort of errors related to
>> > libraries.
>> >
>> > Anyhow, sorry for the rant, but this is happening with the teachers
>> > just logging in. Students show up next week.
>> >
>> > Sincerely,
>> > Dave Hopkins
>> >
>>
>> _______________________________________________
>> K12OSN mailing list
>> K12OSN redhat com
>> https://www.redhat.com/mailman/listinfo/k12osn
>> For more info see <http://www.k12os.org>
>>
> --
> James P. Kinney III
> CEO & Director of Engineering
> Local Net Solutions,LLC
> http://www.localnetsolutions.com
>
> GPG ID: 829C6CA7 James P. Kinney III (M.S. Physics)
> <jkinney localnetsolutions com>
> Fingerprint = 3C9E 6366 54FC A3FE BA4D 0659 6190 ADC3 829C 6CA7
>
>
> --
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]