[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Re: CUPS stopping after printing one job



Try it again when that job hangs.

--TP

Ronnie Miller wrote:
I tried this and the response is:

"E214LaserPrinter is ready and printing"

Same thing when I look at CUPS. The problem is that a job will hang for no
apparent reason and sit there until I eventually clear it. It's a random
thing with no rhyme or reason that I can see.

I'll admit it - I'm confused.

-------------------------------------------------------------------------------------------
    * From: "Terrell Prude' Jr." <microman cmosnetworks com>
    * To: "Support list for open source software in schools." <k12osn
redhat com>
    * Subject: Re: [K12OSN] CUPS stopping after printing one job
    * Date: Wed, 27 Aug 2008 00:54:35 -0400

Terrell Prude' Jr. wrote:

    Ronnie Miller wrote:

        I'm having an issue with cups printing in my k12ltsp labs. Both are

        running Centos 5 with all updates applied. My problem is that when
a class

        is printing to the lab printer, the first job or two prints and
the rest

        never get printed. It's as if the print service hangs up on the
second or

        third job.


        Usually, I have to clear previous jobs using http://localhost:631
and the

        CUPS admin screens to get the printer working for them to print in
the

        first place. Both are set up as IP printers. Is there something
simple I'm

        missing?

        Any help is always appreciated.

    My Dad ran into a similar issue just today. Here's how I fixed it for
him.

    I did an "lpq -P MyCaseSensitivePrinterName" at a terminal window. I
saw a bunch of jobs, preceded by this message:

      printer is not ready



    If you see that, then take a look at the /etc/cups/printers.conf and
look for the following:


       State Stopped
       StateMessage /usr/lib/cups/backend/lpd failed


    What you do to fix this is as follows.


    Edit /etc/cups/printers.conf, delete both of those lines, and replace
them with this:

       State idle


    and restart the CUPS daemon (as root) with "/sbin/service cups
restart". That ought to get your jobs printing again.

    But this could happen again and again, you say! Will I have to do this
every time?? The answer is no, you won't. What's happening here is
that, for whatever reason, CUPS is timing out in talking to the
printer and thus administratively downs the printer. What it *should*
do, ideally, is simply try again (maybe the printer cable got kicked,
or it was powered off, or whatever). And we can, indeed, make that
happen!

    Again, in /etc/cups/printers.conf, replace the following line

       ErrorPolicy stop-printer

    with this

       ErrorPolicy retry-job


    and things should be just peachy from here out. Remember to restart
the CUPS daemon after this change as well so that it takes effect.

    --TP

Slight edit: The line should be "State Idle" instead of "State idle"
above. This may indeed be case sensitive. Hey, I'm a little tired. :-)

--TP






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]