[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] How to update K12LTSP-5.0.0EL-32bit chroot



I have a number of kickstarts based on centos 5.4 deployed to my
customers.  many of them have jammin tc's that they connect sheetfed
scanners to. I was able migrate the chroot and tftpboot kernels from the
k12 iso to my kickstart image without any issues.

 we were using the avision av210c2 and everything worked great.
Unfortunately, as manufacturers often do, they discontinued that model
and we are now getting av210D2+ models. that required an upgrade to the
sane-backend. we were able to hack together an rpm which runs fine on
the server. scanner works. i cant however get the backend to work on the
jammin , primarily due to libc, hence my desire to upgrade the jail.

I tried the same method of moving the chroot and kernels with the fed9
and fed10 ltsp packages, but i am having issues with the tc's dhcp call
after it loads the kernel image connecting on standard port 67 instead
of my alt 1067. I tried kludging the fed9 and k12 chroots and managed to
get it to give me a telnet login prompt but I am having a prob loading
an x desktop. x runs, a conn to port 7100 is established, but i have a
problem with ldm loading a desktop.

It doesnt matter to me what method i get working, updating the chroot on
the centos iso or migrating the chroot and kernels from a fedora distro
as long as i can get an x desktop and my scanner to work.





On Tue, 2011-02-08 at 11:22 -0500, Terrell Prude' Jr. wrote:
> Should that matter, though?  Remember that the only app actually running
> on the thin client is X11.  All the apps run on the server and merely
> get displayed via X11 on the client.  Thus, all the apps will use the
> server's own libc (v2.5).  I've actually taken a Sun UltraSPARC box
> running Red Hat Linux 6.2--yup, the really ancient one from 11 years
> ago--and, doing an X11 indirect query, used that box as a K12LTSP 5EL
> thin client (it worked like a champ).
>
> Is there something specific you need to do on the thin client that
> requires the newer libc on the client itself?
>
> --TP
>
> Stephen Kerr wrote:
> > Hi Terrell, thanks for responding.
> >
> > Specifically the libc package in the chroot is 2.3.2 while libc in the
> > host centos install is on 2.5 . My main reason for moving off of 4.2 was
> > to update libc.
> >
> >  I have started looking into copying the ltsp-build-client script and
> > components under /usr/share/ltsp over and running it on the centos box
> > but am running into issues there as well.  maybe my google-fu is not up
> > to snuff, but I havent been able to find any way to update the chroot.
> >
> > On Tue, 2011-02-08 at 09:55 -0500, Terrell Prude' Jr. wrote:
> >
> >> When you say they're too old, what does that mean?  Are some things not
> >> working?
> >>
> >> --TP
> >>
> >> Stephen Kerr wrote:
> >>
> >>> I recently downloaded K12LTSP-5.0.0EL-32bit-dvd.iso, set it up with a
> >>> single nic and running dhcp on an alternate port. All works great. I am
> >>> having one show stopper however, many of the packages under the chroot
> >>> are too old for my purposes. Can someone suggest the best way to go
> >>> about updating them ? Yum update has updated to CentOS 5.5 final but
> >>> nothing under /opt/ltsp has changed.
> >>>
> >>> Thanks,
> >>> Steve
> >>>
> >>> _______________________________________________
> >>> K12OSN mailing list
> >>> K12OSN redhat com
> >>> https://www.redhat.com/mailman/listinfo/k12osn
> >>> For more info see <http://www.k12os.org>
> >>>
> >>>
> >> _______________________________________________
> >> K12OSN mailing list
> >> K12OSN redhat com
> >> https://www.redhat.com/mailman/listinfo/k12osn
> >> For more info see <http://www.k12os.org>
> >>
> >
> >



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]