[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: no kick from kickstart



Regarding kickstart failing with "no install method specified for
kickstart":

I replaced /sbin/loader inside initrd.img on the bootnet.img floppy from
RH7.0.  I rebuilt from source, added debugging, and used "loader-network"
for the new copy.

It took some digging, but I finally realized that my ks.cfg file was
mode 600.  Hence root on the machine being kickstarted could not read it
over nfs.  Instead, the loader ended up with an empty file in /tmp/ks.cfg.
I tried to enhance the error checking in loader/misc.c, but open(),
access() and read() all work without returning an error.  Yet the end
result is incorrect.  There's a problem here but I can't see the fix
for it.



I also found a minor bug in that the nfs mount to access the kickstart
file was not correctly being unmounted.  bugzilla'd it.


And another bug, unless I'm not understanding correctly.  The
documentation seems to say partition information should be entered as

    part /boot --size 20   --asprimary 1

However, looking at the python code which uses getopt, I believe the
correct way is

    part /boot --size=20   --asprimary=1

The documentation is inconsistent, in that --bytes-per-inode and --type
both have the "=value" format while all the other options show the
" value" format.  bugzilla'd it too.

Jim





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]