[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: partitioning in %pre



James,

What version of RedHat are you using.  RH 9.0 has a couple of problems in
this
area:
      1) it does not  installing over the top of pre-existing raid devices
                   and trying to setup raid very well (think python
exception).
      2) It does not handle installing over the top of prexisting raid
devices, and
          not using raid (think of it using the wroing devices when it
mounts things;
          seems to prefer raid devices to non-raid devices).

The answer to one is to tell mdadm to clear the raid superblock, and use
tune2fs to clear the filesystem label.  The answer to the second problem is
all of the above, but to also clear the non used drives partition table.

There was a long question about this on the anaconda list recently but it
got no response.

Cheers...james



                                                                                                                                           
                      James_Martin ao usco                                                                                                 
                      urts.gov                     To:      kickstart-list redhat com                                                      
                      Sent by:                     cc:                                                                                     
                      kickstart-list-admin         Subject: partitioning in %pre                                                           
                      @redhat.com                                                                                                          
                                                                                                                                           
                                                                                                                                           
                      04/03/03 12:35 PM                                                                                                    
                      Please respond to                                                                                                    
                      kickstart-list                                                                                                       
                                                                                                                                           
                                                                                                                                           




I'm trying to setup a 50MB partition in %pre that will house the Compaq
System Partition.  Here's what I've got so far:

####
%pre

#create the disk device

mknod /dev/cciss/c0d0

#wipe out current disk

echo | fdisk /dev/cciss/c0d0 << EOF
o
w
EOF

echo | fdisk /dev/cciss/c0d0 << EOF
n
p
1

+50M
t
1
12
w
EOF

###

Unfortunately when I do this, anaconda fails when it tries to partition the
disk.

Any pointers?

Thanks,

James S. Martin, RHCE
Contractor
Administrative Office of the United States Courts
Washington, DC
(202) 502-2394



_______________________________________________
Kickstart-list mailing list
Kickstart-list redhat com
 https://listman.redhat.com/mailman/listinfo/kickstart-list








[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]