[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NFS kickstart fails with e1000.ko drivers



Joe Robertson wrote:
I believe this is probably an anaconda problem but since it only shows up when I'm trying
to do kickstart I will send it here.
Question: Has anyone has been successful in running kickstart via NFS through an Intel 82546EB network interface?
I'm fighting a problem getting kickstart to run with these NICs (using NFS). It appears to be related to the NIC in use.

I think I ran into the same issue with a new MSI 1U system. I tried to follow some documentation I found on this list and at the below link for adding a new driver to the boot kernel (which I tested successfully on an already installed machine--so the driver works), and adding the ID 0x1075 and 0x1076 for the cards in my machine to the pcitable in the kickstart image, but the install still fails when trying to load the network drivers. I found someone else who had removed the e100 driver and that solved a similar problem, so I tried that, and it also failed.


I'd be pleased as punch if someone would tell me what I missed in my modifications of the kickstart initrd image, that would make this work...Even a simple list of files that must be changed when adding a new or modified driver to the kickstart image (so I could spot the one I didn't change) would be exceedingly useful.

Some links that were helpful (but didn't result in a working solution):

http://blog.oddbit.com/tech/new_install_kernel.html
http://www.puschitz.com/Kickstart.shtml

An additional data point, a Fedora Core 2 test2 PXE image worked up until the point where it complains about the boot image not matching the installation directory. So the kernel in fc2t2 works fine, but it won't let me install fc1.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]