[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: RHEL5/CentOS5 KS Network Oddities (ifcfg-* gets re-written)



Christian,

Very interesting.  I've been doing a lot lately with RHEL5, both manually and via
kickstart.
My KS server is Fedora 7, though that really shouldn't matter.  For my own
education, I would
very much like to see an anonym zed display of the files you've mentioned before
and to see
what your method is for doing this.

I agree with you, that the behavior you are looking for is normal.  Some want to
manage their
static IP's via DHCP, yet I've worked with large-scale enterprises that decry
DHCP entirely.
Meaning their entire world is static, period.  Its a choice for how to manage the
infrastructure.

You said using firstboot 'disabled' via your ks.cfg didn't help.  Can you please
elaborate?

One tool I've been using is 'zlister' during the initial phase of the %post
section, then when
I'm all done manipulating the system, then I run it again as the VERY first
'thing' I do once
I log it, no matter WHAT issues/problems I'm having or wish to solve.  Its a set
of scripts
that let me list the entire filesystem (akin to tripwire, kinda) and then do
context-diff's
of filesystem listings against previous runs.  I can speak more to this if
desired, but its
simply a tool I use.

R,
-Joe Wulf, CISSP, USN(RET)
 Senior IA Engineer
 ProSync Technology Group, LLC
 www.prosync.com


-----Original Message-----
From: kickstart-list-bounces redhat com
[mailto:kickstart-list-bounces redhat com] On Behalf Of kslist
Sent: Tuesday, September 25, 2007 19:03
To: kickstart-list redhat com
Subject: RHEL5/CentOS5 KS Network Oddities (ifcfg-* gets re-written)

Hello KSers,

I am using my Kickstart script that I have adapted from RHEL 2.1, 3, and 4 now on
CentOS 5. CentOS 5 behaves differently when it comes to network configuration.

In essence: AFTER the successfull installation, during the first startup of the
OS, something desctroys my network configuration. Specifically, the files that I
have directly written in my %post script:
/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-eth1
/etc/hosts
/etc/resolve.conf
are modified, and in the case of the ifcfg-* scripts, my scripts are moved to a
*.bak file (which have a datestamp later than the files I created via %post, and
which correspond to the firstboot) and a completely newfile is created in its
place.

The network configuration that replaces my own is one for DHCP.

My guess is that this is a result of a change in behaviour of the "network"
option. To quote from the RHEL 5 Installation Guide:

"Configures network information for the system. If the kickstart installation
does not require networking (in other words, it is not installed over NFS, HTTP,
or FTP), networking is not configured for the system. If the installation does
require networking and network information is not provided in the kickstart file,
the installation program assumes that the installation should be done over eth0
via a dynamic IP address (BOOTP/DHCP), and configures the final, installed system
to determine its IP address dynamically. The network option configures networking
information for kickstart installations via a network as well as for the
installed system."

Now, I see a problem here:
- I use DHCP to install the system (via Kickstart)
- I however do NOT want to run the subsequently installed OS to use DHCP.

I would say that is a very very normal thing to want.

However, the way the manual describes it, and from the behaviour I have seen, it
is not possible to install via DHCP, and then setup your own network
configuration in %post, because your configuration will be overwritten next time
you boot the system.

Ussing "firstboot --disable" doesn't help.

Please help!

-Christian

_______________________________________________
Kickstart-list mailing list
Kickstart-list redhat com
https://www.redhat.com/mailman/listinfo/kickstart-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]