[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Old style fixed partitions in KS-- Anaconda bug??



In regard to: Re: Old style fixed partitions in KS-- Anaconda bug??, Cris...:

I'm also curious-- if your suggestion above works (where you
partition the disk with sfdisk and then use LVM), I'm even more
curious why my version doesn't work-- I'm doing the same thing, just
more statements of the form: "part /boot --fstype ext3  --onpart=hda1".

I used this just recently on RHEL 4.6, and it worked fine.  I did
partitioning manually in %pre (I didn't have time to get sfdisk right,
though your examples will undoubtedly help me down the road...), and
also created the filesystems and the basic LVM in %pre too.

zerombr yes
#
# TVM: don't do anything to the disk label.
#
clearpart --none

#/boot
part /boot  --noformat --onpart=hda1

# swap
part swap   --noformat --onpart=hda2

# /
part    /   --noformat --onpart=hda3

# remainder for LVM
part pv.01  --noformat --onpart=hda4

volgroup localvg1 pv.01 --noformat

logvol /usr/local   --noformat  --name=local    --vgname=localvg1
logvol /tmp         --noformat  --name=tmp      --vgname=localvg1
logvol /var         --noformat  --name=var      --vgname=localvg1
logvol /home        --noformat  --name=home     --vgname=localvg1
logvol /u01         --noformat  --name=oracle   --vgname=localvg1




Tim
--
Tim Mooney                                        Tim Mooney ndsu edu
Information Technology Services                   (701) 231-1076 (Voice)
Room 242-J6, IACC Building                        (701) 231-8541 (Fax)
North Dakota State University, Fargo, ND 58105-5164


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]