[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kickstarting to VM via ISO image



gene huft wachovia com wrote:
I got this problem solved - I hadn't realized the .discinfo file didn't get copied off media during my rsync ..anyway, I restored it & it makes it through the install.

Now, however, it will not execute the %post section - in which I call another script that I try to copy off from a directory on virtual CDROM (ISO) that I'm building from... my question is: during %post, how is the cdrom mounted, another words, do I have to mount the cdrom in the script something like mount -t iso9660 -o ro /dev/cdrom /media ? Or do I use a %post --chroot in some fashion?
Gene L. Huft
Distributed Systems Engineering
------------------------------------------------
512-310-4104
512-673-0717 (Cell)
Gene Huft Wachovia com
----- Forwarded by Gene Huft/IT/WACH on 03/05/2008 09:21 PM -----

Gene Huft/IT/WACH 03/05/2008 02:43 PM

To
kickstart-list redhat com
cc

Subject
Kickstarting to VM via ISO image





Kickstart Gurus,

I have a fully contained ISO image of the original RHEL5.1 32-bit source tree, along with some additional RPMs & a custom ks.cfg file. The goal is to totally automate the build to a VMware VM via mapping the ISO file to a virtual CDROM.
I have modified the default isolinux/isolinux.cfg file as follows:

default xander
prompt 1
timeout 600
display boot.msg
F1 boot.msg
F2 options.msg
F3 general.msg
F4 param.msg
F5 rescue.msg
label xander
  kernel vmlinuz
  append initrd=initrd.img ramdisk_size=8192 ks=cdrom:/ks.cfg
label text
  kernel vmlinuz
  append initrd=initrd.img text
label ks
  kernel vmlinuz
  append ks initrd=initrd.img
label local
  localboot 1
label memtest86
  kernel memtest
  append -


In my kickstart file, I of cource specify "cdrom". The ISO image will boot the VM into RedHat's initial screen, but when hit return or let it time out it, it complains that it cannot find the install media on any cdrom. I also tried to put the kickstart file into the initrd.img by uncompressing image, copying ks.cfg into it, modifying isolinux.cfg to:

append initrd=initrd.img ramdisk_size=8192 ks=file:/ks.cfg

Then recompressed it, moved it into proper place & re-generated ISO image. Again, the ISO will boot the VM to initial RH screen, but soon there after get the "cd not found" error. Is this just a VMware thing? My coworker has no trouble with SuSE builds working....am I overlooking something simple?



I rarely use CD/DVD for installs, esp ks installs, so add salt.

I think the CD is directly accessible if your %post is not chroot. Have a look at vc1 during any install to see what's there.

I think the CD is not directly accessible if your %post is chroot. It's possible to mount it, but doing so requires some effort, or basic assumptions relying on the way you work. Simplest, is to copy from a non-chroot %post and use from a chroot %post. It's legitimate to have more than one (and for them to be in different languages).




--

Cheers
John

-- spambait
1aaaaaaa coco merseine nu  Z1aaaaaaa coco merseine nu
-- Advice
http://webfoot.com/advice/email.top.php
http://www.catb.org/~esr/faqs/smart-questions.html
http://support.microsoft.com/kb/555375

You cannot reply off-list:-)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]