[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] febootstrap failure



Richard W.M. Jones wrote:  [Sat May 15 2010, 02:15:17AM EDT]
> On Fri, May 14, 2010 at 11:02:36PM -0400, Aron Griffis wrote:
> > Hi again Rich,
> > 
> > I'm trying to use febootstrap to install either rawhide or f13,
> > but my attempts are failing.
> > 
> > $ sudo febootstrap fedora-13 /mnt/jubjub-f
> > ...
> > Running rpm_check_debug
> > ERROR with rpm_check_debug vs depsolve:
> > libc.so.6()(64bit) is needed by procmail-3.22-25.fc12.x86_64
> > libc.so.6(GLIBC_2.2.5)(64bit) is needed by procmail-3.22-25.fc12.x86_64
> > libc.so.6(GLIBC_2.3)(64bit) is needed by procmail-3.22-25.fc12.x86_64
> > libc.so.6(GLIBC_2.4)(64bit) is needed by procmail-3.22-25.fc12.x86_64
> > libm.so.6()(64bit) is needed by procmail-3.22-25.fc12.x86_64
> > libm.so.6(GLIBC_2.2.5)(64bit) is needed by procmail-3.22-25.fc12.x86_64
> > libc.so.6()(64bit) is needed by gawk-3.1.7-3.fc13.x86_64
> > libc.so.6(GLIBC_2.11)(64bit) is needed by gawk-3.1.7-3.fc13.x86_64
> > libc.so.6(GLIBC_2.2.5)(64bit) is needed by gawk-3.1.7-3.fc13.x86_64
> > libc.so.6(GLIBC_2.3)(64bit) is needed by gawk-3.1.7-3.fc13.x86_64
> > libc.so.6(GLIBC_2.3.4)(64bit) is needed by gawk-3.1.7-3.fc13.x86_64
> > libc.so.6(GLIBC_2.4)(64bit) is needed by gawk-3.1.7-3.fc13.x86_64
> > ...
> 
> Don't run febootstrap as root.

I'm a little confused about that. I understand the concept of
fakeroot and fakechroot but I must be missing a piece of the
puzzle. I want to build up a Fedora install that I will
eventually boot into. At that point root should own the files.
How does this work if I run febootstrap as a normal user?

I did attempt to run febootstrap as myself, but got the same
error shown above.

> You don't say what version of febootstrap you are using or what host
> you're using it from.

I'm running on Ubuntu Lucid with the following versions:

    febootstrap  2.1-4
    fakechroot   2.9-1.1
    fakeroot     1.14.4-1ubuntu1
    yum          3.2.25-1ubuntu2

Should I try again from git?  Alternatively I'll just switch to
installing a VM (since eventually this will be that) but I'm
a longtime user of debootstrap so I'm pretty happy to find
febootstrap, assuming it will work for me!

Thanks,
Aron


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]