[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] Unable to build appliance



On Fri, Jun 3, 2011 at 11:23 PM, Richard W.M. Jones <rjones redhat com> wrote:
Which version of febootstrap are you pairing with this old libguestfs?

libguestfs up to ~ 1.7.something required febootstrap 2.x.  After
that, febootstrap 3 is required.


Yes, I've made a list of the valid combinations:

1.  libguestfs 1.2.14 requires febootstrap >= 2.3
2.  libguestfs 1.4.6 requires febootstrap >= 2.7
3.  libguestfs 1.6.2 requires febootstrap >= 2.10
4.  libguestfs 1.8.7 requires febootstrap >= 3.0 (though 3.3 is recommended)

I've tried building each version of libguestfs with the minimum acceptable (or recommended, in the case of #4) version of febootstrap.  #1 is the one I originally posted about; it gets up to running febootstrap, then complains about not finding /sbin/depmod.  #2 and #3 both get to running febootstrap, then error out with "cannot run command `rm': No such file or directory".  I'm trying to build febootstrap 3.3 right now.
 
You need to be really specific about what this "old Ubuntu" is that
you're trying to build on.  What kernel version?

2.6.32-29-generic.
 
 What version of KVM?

0.13.0-0ubuntu1.






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]