[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] Unable to build appliance



On Mon, Jun 06, 2011 at 11:36:20AM -0700, Sean McAfee wrote:
> 2.6.32-29-generic.

I believe this kernel is too old -- it doesn't have virtio-serial
which was added in 2.6.35 or 2.6.36.  Unless you can at least install
a later kernel for guests to use, this is never going to work.

> >  What version of KVM?
> >
> 
> 0.13.0-0ubuntu1.

This should be OK.

Next step is to build febootstrap ideally 3.6.

Then install febootstrap (or adjust your $PATH), and build libguestfs.

Usually to build Debian binary packages you just have to do:

  debuild -i -uc -us -b 2>&1 | tee /tmp/log

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming blog: http://rwmj.wordpress.com
Fedora now supports 80 OCaml packages (the OPEN alternative to F#)
http://cocan.org/getting_started_with_ocaml_on_red_hat_and_fedora


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]