[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] febootstrap-3.12 configure error on Fedora 16



On Mon, Nov 14, 2011 at 04:43:28PM +0100, Andrzej Tobola wrote:
> Hello Richard,
> 
> Can't configure febootstrap-3.12 on Fedora 16:
> 
> $ ./configure
> ............
> checking for aptitude... no
> checking for apt-cache... no
> checking for dpkg... no
> checking for pacman... no
> checking for gzopen in -lz... no
> checking for mke2fs... /sbin/mke2fs
> checking for error_message in -lcom_err... no
> configure: error: in `/home/ato/febootstrap/febootstrap-3.12':
> configure: error: com_err library not found (part of e2fsprogs)
> See `config.log' for more details
> 
> [ato f16 febootstrap-3.12]$ gcc -std=gnu99 -o conftest -g -O2  conftest.c -lcom_err
> /usr/lib/gcc/x86_64-redhat-linux/4.6.2/../../../../lib64/libcom_err.a(error_message.o): In function `et_list_lock':
> (.text+0x18d): undefined reference to `sem_wait'
> /usr/lib/gcc/x86_64-redhat-linux/4.6.2/../../../../lib64/libcom_err.a(error_message.o): In function `et_list_unlock':
> (.text+0x1b6): undefined reference to `sem_post'
> /usr/lib/gcc/x86_64-redhat-linux/4.6.2/../../../../lib64/libcom_err.a(error_message.o): In function `setup_et_lock':
> (.text.startup+0x11): undefined reference to `sem_init'
> /usr/lib/gcc/x86_64-redhat-linux/4.6.2/../../../../lib64/libcom_err.a(error_message.o): In function `fini_et_lock':
> (.text.exit+0xa): undefined reference to `sem_destroy'
> collect2: ld returned 1 exit status
> 
> 
> It seems that sem_* symbols are in -pthread -  thist works OK:
> 
> $ gcc -std=gnu99 -o conftest -g -O2  conftest.c -pthread -lcom_err
> 
> so What must be corrected ?

I don't see this error myself.  I just unpacked febootstrap-3.12 from
the tarball, and ./configure && make works fine.

What does config.log say?

> PS
> You can also add:
> 
>   yum install git mailx autoconf automake texinfo ocaml pcaml-findlib
> 
> to the descripion on how to install on fresh F16.
> to save others from my detective work.

I'm fairly sure you don't need autoconf and automake, to build from
the tarball.  Building from git does of course require these.

OCaml and ocaml-findlib are already mentioned in the README file.

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
New in Fedora 11: Fedora Windows cross-compiler. Compile Windows
programs, test, and build Windows installers. Over 70 libraries supprt'd
http://fedoraproject.org/wiki/MinGW http://www.annexia.org/fedora_mingw


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]