[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] virt-v2v error - Fedora 16



On 01/25/2012 02:03 PM, DE Clay wrote:
This is a basic Fedora 16 install and I know there were several other
users reporting this exact error .. so it's appears to be systemic.

Here's what I have installed:


[root fedora16 ~]# rpm -qa | grep perl-Crypt
perl-Crypt-SSLeay-0.58-6.fc16.i686


[root fedora16 ~]# rpm -qa | grep perl-IO-Socket
perl-IO-Socket-SSL-1.49-1.fc16.noarch


If I uninstall perl-IO-Socket-SSL then virt-v2v runs and
I don't get the error.


I just posted a fix for this upstream. It seems something changed about the way Net::HTTPS loads its SSL module in F16, which broke this.

Matt

--Daron



On Wed, 2012-01-25 at 09:30 +0000, Matthew Booth wrote:
On 01/24/2012 03:42 PM, DE Clay wrote:
Trying to test virt-v2v using ESX.  Running Fedora 16 and virt-v2v
0.8.5.

Command invocation:

virt-v2v -ic esx://testhostname/?no_verify=1 -os testpool --network
default testvm

Result:

Invalid configuration of Net::HTTPS
at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Transfer/ESX.pm line 68.


Couldn't find a resolution to this issue on the net.  Please assist.

You've hit a failsafe of a gross hack required to ensure the correct
validation of an SSL certificate. We specifically require Net::SSL
rather than IO::Socket::SSL. The check you've encountered is that the
one we configured is the one in use. In your case it isn't, which I
confess I have never seen before.

Can you confirm that you have perl-Crypt-SSLeay installed? That should
be enough. It would also be interesting to know if you have
perl-IO-Socket-SSL installed. If you do, what happens if you uninstall it?

Matt


--
Matthew Booth, RHCA, RHCSS
Red Hat Engineering, Virtualisation Team

GPG ID:  D33C3490
GPG FPR: 3733 612D 2D05 5458 8A8A 1600 3441 EA19 D33C 3490


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]