[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] KVM Image not working after expansion



Hello,
          Sorry for late reply..
I installed the libguest from RHEL 6.3 preview packages....

# rpm -qa | grep libg

libguestfs-tools-c-1.16.5-1.el6.x86_64
libguestfs-1.16.5-1.el6.x86_64
libguestfs-tools-1.16.5-1.el6.x86_64

I expanded to Images RHEL 5.5 and Ubuntu 11.10 KVM VM's

They both are working fine...

Thanks for the help....


On Fri, Feb 3, 2012 at 1:37 AM, Richard W.M. Jones <rjones redhat com> wrote:
On Thu, Feb 02, 2012 at 03:21:10PM +0530, vipul borikar wrote:
> Hello,
>          I expanded a KVM image of 4gb to 10 gb ....
>
> My Host machine is RHEL 6.1  and Guest is RHEL 5.5
>
> Command i used is:
> virt-resize --expand /dev/sda1 RHEL5.5-64bit.img RHEL5.5-10gb
>
> Commands successfully gets executed...
>
> Old disk works fine i mean it boots properly but the new disk stucks at
> GRUB...
> Has any one seen this behavior...
> What should i do to debug this problem..

I would first suggest trying the latest virt-resize.  There are
preview packages available:

http://people.redhat.com/~rjones/libguestfs-RHEL-6.3-preview/

Rich.

--
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming blog: http://rwmj.wordpress.com
Fedora now supports 80 OCaml packages (the OPEN alternative to F#)
http://cocan.org/getting_started_with_ocaml_on_red_hat_and_fedora



--
Thanks 

Vipul Borikar
"Our task must be to free ourselves...by widening our circle of compassion to embrace all living creatures and the whole of nature and its beauty."


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]