[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libguestfs] install errors for libguestfs-1.19.60



I've been using libguestfs-1.18.9 but decided to "upgrade" to 1.19.60.
Using Ubuntu 12.04 with the older version installed via source.
So I went through the same process with the new version of guestfs sources
and got the following errors on 'make install':

make[2]: Nothing to be done for `install-exec-am'.
make  install-data-hook
make[3]: Entering directory `/home/skippy/libguestfs/libguestfs-1.19.60/ocaml'
mkdir -p /usr/lib/ocaml
mkdir -p /usr/lib/ocaml/stublibs
ocamlfind install \
          -ldconf ignore -destdir /usr/lib/ocaml \
          guestfs \
          META *.so *.a *.cma *.cmx *.cmxa *.cmi ./*.mli
ocamlfind: Package guestfs is already installed
 - (file /usr/lib/ocaml/guestfs/META already exists)
make[3]: *** [install-data-hook] Error 2
make[3]: Leaving directory `/home/skippy/libguestfs/libguestfs-1.19.60/ocaml'
make[2]: *** [install-data-am] Error 2
make[2]: Leaving directory `/home/skippy/libguestfs/libguestfs-1.19.60/ocaml'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/skippy/libguestfs/libguestfs-1.19.60/ocaml'
make: *** [install-recursive] Error 1

Was I supposed to remove the older version first? And if so - how?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]