[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] Problem with supermin & zypper



On Thu, 11 Jul 2013 10:50:01 +0300, Or Goshen wrote:
> Hi,
> 
> During compilation of guestfs I get the following error:

> supermin: could not detect package manager used by this system or distro.
> 
> If this is a new Linux distro, or not Linux, or a Linux distro that uses
> an unusual packaging format then you may need to port supermin.  If
> you are expecting that supermin should work on this system or distro
> then it may be that the package detection code is not working.
> make[2]: *** [stamp-supermin] Error 1*
> 
> Now, I installed supermin from git. During configuration it discovered
> zypper:
> 
> *checking for zypper... zypper
> checking for yum... no
> checking for rpm... rpm
> checking for yumdownloader... no
> checking for aptitude... no
> checking for apt-cache... apt-cache
> checking for dpkg... no
> checking if apt-cache depends --recurse is broken... yes
> checking for pacman... no*

The zypper plugin requires the inifiles OCaml library;
make sure configure detects that.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]