[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] xencreate : What is the error with my program ?



Hello Daniel,
Thanks.
I used the virConnectOpen() function.
I did check for the log file entries .I deleted the
log file ,stopped xend and created a new log file and
ran xend .I dont find any help there.
Is there any other mistake that  I am making while
using tht API / writing the XML description?
Thanks,
Dakshina 




--- Daniel Veillard <veillard redhat com> wrote:

> On Mon, Jul 03, 2006 at 02:06:30AM -0700, dasari
> dakshina wrote:
> > Hello,
> > I am getting this error on trying to create a xen
> > domain
> > Unable to create domain .
> > This is the code snippet. I am unable to figure
> out
> > the root cause .
> > Any help will be appreciated ..
> [...]
> >     conn = virConnectOpenReadOnly(NULL);
> 
>   First you should not open a Read Only connection
> to do a domain creation
> this is obviously an operation with side effect.
> Second the best way to debug what's happening is
> check /var/log/xend.log .
> Xend gives back nearly no debug information when an
> operation fails, and
> libvirt really can't guess whatb went wrong, check
> what xend reported.
> 
> Daniel
> 
> -- 
> Daniel Veillard      | Red Hat http://redhat.com/
> veillard redhat com  | libxml GNOME XML XSLT toolkit
>  http://xmlsoft.org/
> http://veillard.com/ | Rpmfind RPM search engine
> http://rpmfind.net/
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]