[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] possible bug in virDomainLookupByID



On Tue, Jul 18, 2006 at 12:57:23PM -0400, Bryan D. Payne wrote:
> > You dont mention whether you are running the test case as root or an
> > unprivileged user ?  Also what config options are in your /etc/xen/xend-config.sxp
> > file ?
> 
> I'm running as root.  My xend-config is attached.

ok, it looks like you have got both the TCP & UNIX sockets for XenD
turned off.  Although libvirt uses the hypervisor for many operations
there are several for which we have to use XenD. Our recommendation
at this time is to enable unix sockets with the following config
option:

(xend-unix-server yes)

> > I'm curious - what is XenAccess you mention here ? Is this some application
> > being developed with libvirt ?
> 
> Yes, XenAccess is a project that I'm working on to provide introspection
> for Xen.  Currently, I use libvirt to obtain the kernel version of a
> running domain, but may use it for more info in the future.  Details
> available here:
> 
> http://xenaccess.sourceforge.net/

Thanks, that looks like an interesting project for me to take  alook at.

Regards,
Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]