[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] ANNOUNCE: Virt-top - a top-like utility for displaying virtualization stats

Hi Richard,

On 07.08.2007, at 10:40, Richard W.M. Jones wrote:
That's a really strange error. I just downloaded and compiled 0.3.1 here with no problem, so it may be something to do with the version of gnutls you are using.

I have installed these rpm packages:


In consideration of the version Daniel is using, these ones are fairly old, but the latest available for my distribution (Scientific Linux)

Can you send me the complete output of ./configure and make please.

Sure! Please find them attached to this mail.

If you're on x86-64 then the binary (http://www.annexia.org/tmp/ virt-top/virt-top- should just work for you. If you're on another arch, or if it doesn't work, then I can install RHEL 4 ES here and guide you through the build process - I've only tried it on RHEL 5 / F7 myself.

I have also a 64-bit machine installed with Scientific Linux 4.5. On that machine I tried to install the rpm mentioned by you:

<rpm log>
[root pcitfiot08 opt]# rpm -ivh virt-top-
error: Failed dependencies:
libc.so.6(GLIBC_2.4)(64bit) is needed by virt- top- libtinfo.so.5()(64bit) is needed by virt- top- libvirt.so.0()(64bit) is needed by virt- top-
<rpm log>

I have no glibc 2.4 rpm package which is supported by our linux support. The same problem is with ncurses. If I understand things right then libtinfo is included in ncurses >= 5.6. We are still using 5.4. No newer package is available.

Is my distro to old for libvirt > 1.9 and vir-top? Or ist there any chance to get those things working without updating the whole system?



Attachment: config.log
Description: Binary data

Attachment: make.log
Description: Binary data

Attachment: smime.p7s
Description: S/MIME cryptographic signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]