[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] what is virt-install doing differently?



Hi Daniel,

Daniel P. Berrange wrote:  [Tue Jan 23 2007, 10:49:07AM EST]
> For HVM installs, the different should only be the addition of the
> CDROM device. If you take a look in /var/log/xen/xend.log it should
> show you the final SEXPR that XenD is getting when creating the
> guest. Comparing the SEXPR seen when booting the config file, vs
> that generated by virt-intsall may shed some more light on the
> problem.
> 
> Also, virt-install has a --debug flag which will make it show the libvirt
> XML description it used to boot.

Thanks for these suggestions.  Yongkang looked at xend.log and found
this:

You, Yongkang wrote:  [Thu Jan 25 2007, 10:26:33AM EST]
> Thanks for the information. I have check /var/log/xen/xend.log.
> Found something interesting. When using virt-install to install VTI
> domain, it seemed didn't parse the right vcpu number to qemu-dm.
> Please look at the following log:
> 
> 1. The spawning qemu log, when installation by virt-intall with vcpu=4:
> ---------------------
> [2007-01-25 23:14:13 xend 2817] INFO (image:418) spawning device models: /usr/lib/xen/bin/qemu-dm ['/usr/lib/xen/bin/qemu-dm', '-d', '9', '-m', '1024', '-boot', 'c', '-acpi', '-domain-name', 'test', '-net', 'nic,vlan=1,macaddr=00:16:3e:0a:d2:86,model=rtl8139', '-net', 'tap,vlan=1,bridge=xenbr0', '-vncunused', '-vnclisten', '127.0.0.1']
> ~~~~~~~~~~~~
> 
> 2. The spawning qemu log, when use command "xm create":
> ------------------------
> [2007-01-25 17:13:13 xend 2817] INFO (image:418) spawning device models: /usr/lib/xen/bin/qemu-dm ['/usr/lib/xen/bin/qemu-dm', '-d', '7', '-m', '1024', '-boot', 'd', '-vcpus', '4', '-acpi', '-domain-name', 'ExampleVTIDomain', '-net', 'nic,vlan=1,macaddr=00:16:3e:31:42:c4,model=rtl8139', '-net', 'tap,vlan=1,bridge=xenbr0', '-vncviewer']
> ~~~~~~~~~~~
> 
> There is "-vcpus 4" in the 2nd log. It means qemu would create up
> a 4 vpucs VTI domain. 
> 
> For the situation 1, although qemu doesn't get any information about
> "vcpu=4". But xen has already prepared 2 vcpus to qemu. Will it be
> the problem? 

I'm looking through the code now to see if I can find where this is
going awry, but while I'm looking, does this ring a bell for you?

Thanks,
Aron


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]