[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvir] Re: Virtualization things.



On Di Juli 10 2007, Richard W.M. Jones wrote:

> Till Maas wrote:

> > What I did so far was creating a new machine with a Fedora Live CD Image
> > and booted it. When I hit the Pause button, it appeared to be pressed,
> > but nothing happened. The machine still responded and the following error
> > appeared on the commandline, where I started virt-manager:
> >
> > -------------
> > libvir: QEMU error : operation failed: suspend operation failed
> > Traceback (most recent call last):
> >   File "/usr/share/virt-manager/virtManager/console.py", line 389, in
> > control_vm_pause
> >     self.vm.suspend()
> >   File "/usr/share/virt-manager/virtManager/domain.py", line 365, in
> > suspend self.vm.suspend()
> >   File "/usr/lib/python2.5/site-packages/libvirt.py", line 350, in
> > suspend if ret == -1: raise libvirtError ('virDomainSuspend() failed',
> > dom=self) libvirt.libvirtError: virDomainSuspend() failed operation
> > failed: suspend operation failed
> > --------------
>
> This is a bug.  Do you know what version of libvirt & virt-manager this
> happens with?  Suspend _ought_ to work with QEMU with libvirt >= 0.2.0.

I am using an uptodate Fedora 7:

dkms-kqemu-1.3.0-0.2.pre11
qemu-0.9.0-2.fc7
libvirt-0.2.3-1.fc7
virt-manager-0.4.0-2.fc7

> > Then when I shut down the machine and clicked on "run", it did not boot
> > the ISO Image I selected while creating the machine, but only complained
> > that it could not boot from HD (which is true, because I did not install
> > anything to the HD)
> >
> > Then I wanted to delete the machine, but the "Delete" button was still
> > greyed out, even when I shut it down (Imho it should be available all the
> > time and provide a warning that the machine needs to be shut down before
> > it can be deleted). When I closed virt-manager and opened it again, then
> > I was able to delete the machine.
> >
> > But I cannot find a way to add an iso image to the machine or make it
> > boot the iso image I selected at creation time.
>
> I haven't played with live CDs & virt-manager at all, but I'll have a
> go.  What live CD were you trying?

I tried the Fedora 7 rescue CD and the Gnome Live CD, but I not boot further 
than into grub to test "Pause" or shut it down and tried to boot it again.

> > Also the network selection seems not to work, when I want to add a
> > network interface, I can choose between virtual and shared device, but
> > both only have an empty list, where I have to select something to be able
> > to click on "Forward".
>
> This is another bug.  If you get me the version of virt-manager, I'll
> look into it.

See above,

Regards,
Till


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]