[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] Xen reboot does not work with Sys::Virt perl binding



On Thu, Jul 12, 2007 at 01:46:51PM +0200, Keck, Christian (ext) wrote:
> Hello guys!
>  
> I am using the perl bindings (Sys::Virt) to manage my virtual xen hosts.
> Because it directly maps the C api, I thought it's a good idea to ask
> you instead of the author of this module.
>  
> Xen version is 3.0 with libvirt 0.1.9 on a red hat box.
>  
> while calling the reboot method i get following error:
> libvirt error code: 0, message: Unknown problem
> 
> In this case the virtual system does not reboot. 
> But with shutdown method, which throw the same error, the system shuts
> down correctly.
>  
> Here is my code:
> my $vmm = Sys::Virt->new();
> 
> my $dom = eval { $vmm->get_domain_by_name( $p->{ name } ) };
> 
> $dom->reboot(&Sys::Virt::Domain::REBOOT_RESTART);
>  
> Is this a known issue? Thank you for your help.

I've not come across it before, but I'll investigate to try and figure
out what's wrong.

Dan.
-- 
|=- Red Hat, Engineering, Emerging Technologies, Boston.  +1 978 392 2496 -=|
|=-           Perl modules: http://search.cpan.org/~danberr/              -=|
|=-               Projects: http://freshmeat.net/~danielpb/               -=|
|=-  GnuPG: 7D3B9505   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505  -=| 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]