[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libvir] Add scheduler patch?



Hi, Daniel

I confirmed to work Xen3.1.0 only.
And not run on Xen3.0.4.(I guess domctl hypercall problem.)
And not tested yet for Xen3.0.3.

This is the reason I limit to work this command.

Thanks
Atsushi SAKAI


Daniel Veillard <veillard redhat com> wrote:

> On Mon, Jun 04, 2007 at 06:28:26PM +0900, Atsushi SAKAI wrote:
> > Hi, Daniel
> > 
> > I plan to post Xen/SEDF patch.
> > Anyway I hope current patch will apply first,
> > Since coding frame of this command is fixed previously.
> 
>   I'm going though your code right now. I find something suspicious:
> in xenHypervisorGetSchedulerParameters you check
> 
>     /*
>      * Support only dom_interface_version >=5
>      * (Xen3.1.0 or later)
>      */
>     if (dom_interface_version < 5) {
>         virXenError(VIR_ERR_NO_XEN, "xenHypervisorGetSchedulerParameters unsupported in dom interface < 5", 0);
>         return -1;
>     }
> 
> And I don't see why ! The two next hypercalls, the system one to get the
> scheduler ID and the domain one to get the scheduler parameters both exist
> on the xen-3.03 available for example in RHEL-5.0. So why exit with an
> error there ?
> 
> Daniel
> 
> -- 
> Red Hat Virtualization group http://redhat.com/virtualization/
> Daniel Veillard      | virtualization library  http://libvirt.org/
> veillard redhat com  | libxml GNOME XML XSLT toolkit  http://xmlsoft.org/
> http://veillard.com/ | Rpmfind RPM search engine  http://rpmfind.net/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]